How To Fix The [Ext.Loader] “Synchronously loading … consider adding … explicitly as a require of the corresponding class” In Sencha Touch

While this message is not really something that will affect your web app, people like me tend to see warning messages as annoying and as such will go to great lengths to find a solution that will avoid having this warning message appear in the console.

The sample below indicates an Ext.Label declaration is missing.

To fix this, all you need to do is go to app.js and add this class in the requires field.

You can also add them within your view, controller and other classes if you wish to specifically require them within those scopes. However, the global option is more hassle free.

That’s it! That should clear those warning messages.

Related Posts Plugin for WordPress, Blogger...

3 comments

  1. Hello i’ve got the same problem, and I added the required fields inside the app.js > Ext.application
    requires: [‘Ext.MessageBox’,’Ext.field.TextArea’,’Ext.field.Email’],

    No more warnings but I got nothing appear from my view which i already added to my app, I get the empty fields but with no labels?!!!

    Ext.define(‘GS.view.Contact’,{
    extend: ‘Ext.form.Panel’,
    xtype: ‘contactform’,
    config: {
    title: ‘Contact’,
    iconCls: ‘user’,

    items:[
    {
    xtype: ‘textfield’,
    name: ‘name’,
    lable: ‘Name’
    },
    {
    xtype: ’emailfield’,
    name: ’email’,
    lable: ‘Email’
    },
    {
    xtype: ‘textareafield’,
    name:’message’,
    lable: ‘Message’
    }
    ]
    }
    }
    );

Leave a Reply

Your email address will not be published. Required fields are marked *